Traincraft 4.2.1.

MrbrutalTraincraft68 Comments

2014-07-03_14.26.07

We’ve made a new version and probably the last of 1.6.4. versions, before switching to 1.7. This brings further bugfixes to tracks, and a few new models, thanks to Ontax and Skspajdalfsks for making them.

 

If all the new trains don’t show up, delete the Traincraft.cfg file and restart MC.

You can download the mod here, or even better on our new site here. (Updated by the end of the week!)

You can read the changelog here.

MrbrutalTraincraft 4.2.1.

68 Comments on “Traincraft 4.2.1.”

  1. hermanberk

    Im loving the new trains, but i found a few bugs, the sounds of the adler seems to be static, and the CD 742 doesnt have sounds at all! also, the front of all trains and carts doesnt seem to stick to the rails, so if you take a turn the front hangs over the turn. (i dont think this happend in the version before this one) and lastly the logging caboose and the N.Y. Subway (passenger cart) seem to be replaced with the adler’s tender and its passenger cart. but still, this mod is awesome and i am sure this is fixed easely, keep up the good work !
    -hermanberk

      1. AlexNuget

        when i do that it crashes but would this fix my problems that are;
        the adlers tender is a logging caboose
        the N.Y.C subway passenger car is the alder passenger car

    1. A guy

      “We’ve made a new version and probably the last of 1.6.4. versions, before switching to 1.7.”
      Just a quote from over there.

  2. ty

    how the crap do u download this mod??? i tried like 10 times and it dosen’t work!! help!!!!!!!!

  3. Willi

    please enter the two ways crossing again to 1*1 change . than 5 * 5 you can use it anywhere .
    and change the medium switch to 3 * 3 . so that it is suitable for parallel switch .
    mfg willi

  4. Parker

    Do you guys have any test builds for 1.7.10, or plan on going to 1.7.10? I’d love to donate and get access to test builds like I do with railcraft. 😀

  5. Walnut

    I meet a amazing bug or conflict,the key “S” wasn’t work,I can’t decelerate trains with usual method,but to use W opposite.What should I do?

  6. Adam

    Hi. I want to create some slovak and czech trains like zssk 810, zssk 751, zssk 754… I think that you creating models in techne. Please can you send me one finished model (if you can cd 742) and wheel axis as template? Thanks

    1. Mysopias

      They don’t use techne, I believe it is MC model creator, or something along those lines, that way you have angles.

  7. Scott

    My friends and I made a lot of track to places on our map. Most track is suspended in the air and is 3 blocks wide with the track in the middle. We have found out that if you get out of the trains (white Speed train and the big green train, both electric) you get thrown from the platform area. But if there are two blocks at the exit point you will not get thrown. Would be nice if you could have this fixed for 1.7 versions. Otherwise we love this mod.

  8. Dovahkiin

    it crashes minecraft. i have mods like thermal exp., buildcraft, univrsl. electricity, etc. do they conflict?

    1. RedRaptor5

      Okay, 1: It’s called the “Bountiful Update”, not “Boundfull” or whatever…
      and 2: no, it won’t work on 1.8 or any 1.7 versions for that matter. The latest version they’ve made it for is, once again as stated above, 1.6.4.

  9. aryo seno

    I have found a new bug, a lil bit hard to tell, so whenever the train makes it to the right, the locomotive engine rotates itself 180 lol, and it happens when I am far off from the train itself, when the train is in the fog. However when im close to the train, it just doesnt happen….

  10. Elfnet

    really guys, 1.6.4 MC? How about we get with the program and make this updated to 1.7.10 or 1.8 , otherwise release the source so someone else can update it and post your retirement if your not going to update this mod yourself…

    1. Minecarftmano9

      First off knuckle head, I would like to see you try this! Also if you look at the rest of the blog not just the ones that say UPDATE, you’ll see that they are recoding the whole mode! That takes a while, just be happy that we got these awesome people that loved trains so much, that they went through the trouble of making this awesome mode for mc! If you think you can do a better job at it try and make a mode your self and see what they go theough! Next time you say something like that I can bet you that I won’t be the only one who puts you in your place!

      1. Miner_51

        Does he understand what it takes to make a mod? its not like poof! you have it. its more like type,type,more type, release, oh there’s a bug type,type,etc

  11. GENESIS OnAir

    When I try to load the game it just closes minecraft and doesnt show up I NEED HELP (I am using the new 1.6.4 version)

    1. Mrbrutal

      I’d need logs to help with the problem, but please don’t paste them here. Put them up on pastebin and mail them to me please.

  12. JasonBlu

    hurry up and update to 1.7.10 i hate waiting i been waiting for 1.7.10 cause i cant seem to work forge 1.6.4 nor any version except 1.7.10 and hirer

  13. Jordy Smeets

    Will there ever be a orient express model? perhaps restaurant car with furnace and sleeping car with bed (is that even possible?) would love too. am a big wagons lits fan XD

  14. Jaujau

    Patience for the update! im so excited to edit the funland with the roller coaster mod and this mod for 1.7.10! i know its hard to make a mod (since i tried and i got my mind blown so i didnt continue and doesnt work)

  15. Yaro01

    french

    bonjour

    a quand le mod traincraft en version 1.7.10 voir 1.7.2 pour mon server cauldron car rails of war craft n’est pas tres complet et de ombreux conflit
    donc possible de l’avoir assez rapidement mais pas en 2020 s’il vous plait

  16. Colin

    I’ve got it downloaded, and it’s a .jar file. I’ve done everything I can but it won’t open. I’ve double-clicked, I’ve tried to run it using the command prompt, and it just won’t open to install into the game. And I do have java runtime environment. Is there anyway you can help, or anything you can suggest I do?

    1. Sam

      You need to have minecraft forge 1.6.4 installed and have run minecraft after it has been installed. Then there will be a mods folder in C:\Users\(Your user)\ Appdata\Roaming\.minecraft and you need to place the jar file in there. It doesn’t need to be opened

  17. Bailey

    I’m really looking forward to this! I was a big fan of this mod, And the Real Trains Mod is really glitchy…

  18. KillSwitch

    We have waited soooooo long for the 1.7 update, is it still coming out? If it is coming out can we get a release date?

Leave a Reply

Your email address will not be published. Required fields are marked *